AttributeError: ‘module’ object has no attribute ‘add_metaclass’

I’am  installation  Openstack on  Centos7  but  it  is give me  following  error ;


Traceback (most recent call last):
  File "/usr/local/bin/glue", line 9, in <module>
    load_entry_point('glueviz==0.3.0', 'console_scripts', 'glue')()
  File "/usr/local/lib/python2.7/dist-packages/glue/main.py", line 226, in main
    start_glue(config=opt.config)
  File "/usr/local/lib/python2.7/dist-packages/glue/main.py", line 171, in start_glue
    ga = GlueApplication(session=session)
  File "/usr/local/lib/python2.7/dist-packages/glue/qt/glue_application.py", line 195, in __init__
    self._create_actions()
  File "/usr/local/lib/python2.7/dist-packages/glue/qt/glue_application.py", line 505, in _create_actions
    if len(exporters) > 0:
  File "/usr/local/lib/python2.7/dist-packages/glue/config.py", line 62, in __len__
    return len(self.members)
  File "/usr/local/lib/python2.7/dist-packages/glue/config.py", line 44, in members
    self._members = self.default_members() + self._members
  File "/usr/local/lib/python2.7/dist-packages/glue/config.py", line 111, in default_members
    import glue.plugins  # discover plugins
  File "/usr/local/lib/python2.7/dist-packages/glue/plugins/__init__.py", line 2, in <module>
    from . import export_plotly
  File "/usr/local/lib/python2.7/dist-packages/glue/plugins/export_plotly.py", line 5, in <module>
    from plotly import plotly
  File "/usr/local/lib/python2.7/dist-packages/plotly/__init__.py", line 31, in <module>
    from plotly import plotly, graph_objs, tools, utils
  File "/usr/local/lib/python2.7/dist-packages/plotly/plotly/__init__.py", line 10, in <module>
    from . plotly import (
  File "/usr/local/lib/python2.7/dist-packages/plotly/plotly/plotly.py", line 29, in <module>
    from plotly import tools
  File "/usr/local/lib/python2.7/dist-packages/plotly/tools.py", line 21, in <module>
    from . graph_objs import graph_objs
  File "/usr/local/lib/python2.7/dist-packages/plotly/graph_objs/__init__.py", line 12, in <module>
    from . graph_objs import (
  File "/usr/local/lib/python2.7/dist-packages/plotly/graph_objs/graph_objs.py", line 251, in <module>
    @six.add_metaclass(ListMeta)
AttributeError: 'module' object has no attribute 'add_metaclass'

I  follow step this link  http://accelazh.github.io/openstack/Install-Devstack-On-CentOS-7/  Can  I solve  this problem ?

Özge Ayaz Şef on 9 Şubat 2016 yazdı
Yorum Ekle
  • 1 Yanıt(lar)

    I  solved  this  problem  :)  I run  follow  commands  on terminal ;

    sudo pip uninstall six
    
    sudo pip install six
    
    
    Özge Ayaz Şef on 9 Şubat 2016 yanıtladı
    Yorum Ekle
  • Yanıtınız

    Cevabınızı göndererek Gizlilik Politikası ve Hizmet Şartlarını kabul ediyorsunuz.