‘ZLIB_1.2.9’ not found

Hata: ImportError: /lib/x86_64-linux-gnu/libz.so.1: version `ZLIB_1.2.9′ not found …

Merhaba arkadaşlar,

Ubuntu üzerinde virtualenv klasörü içerisinde dlip kütüphanesini günceller iken aşağıdaki gibi bir hata aldım.

“ImportError: libz.so.1: version `ZLIB_1.2.9′ not found (required by /home/hp/anaconda3/lib/libpng16.so.16)
(python35Lib) hp@hp:~/virtu”

Bu hatanın çözüm adımları aşağıda verilmiştir:
1.  zlib-1.2.9 dosyasını indirin.
2. “sudo su” ile root olun
3. “cd zlib-1.2.9” klasörüne geçin
4. “./configure; make; make install” komutunu çalıştırın.
5. “cd /lib/x86_64-linux-gnu” klasörünü geçin
6. ln -s -f /usr/local/lib/libz.so.1.2.9/lib libz.so.1

Bu adımlardan sonra dlib i çalıştırdığınızda sorunun giderildiğini göreceksiniz.

İyi çalışmalar.

KAYNAKLAR:
[1] https://github.com/AllToMP3/alltomp3-app/issues/25#issuecomment-371582608

Semiha Makinist Uzman on 25 Haziran 2018 yazdı
Yorum Ekle
  • 0 Yanıt(lar)
  • Yanıtınız

    Cevabınızı göndererek Gizlilik Politikası ve Hizmet Şartlarını kabul ediyorsunuz.