Python2.7 için dlib kurulumu (install dlib for python2.7)

dlib c++ tabanlı olup derin öğrenme için geliştirilmiş bir kütüphanedir. Python için dlib kütüphanesini kumak için önce boost ve cmake yüklemeniz gerekmektedir. Ben işletim sistemi olarak ubuntu 14.04 kullanmaktayım ve python2.7 üzerinde çalışmalarımı geliştirmekteyim. ilk önce gerekli boost python kuralım.

sudo apt-get install libboost-all-dev

Daha sonra cmake kurulumunu yapalım;

sudo apt-get install software-properties-common

sudo add-apt-repository ppa:george-edison55/cmake-3.x

sudo apt-get update

sudo apt-get install cmake

sudo apt-get upgrade

libopenblas.so.0 hatası almamak için dlib kurulumndan önce libopenblas dosyasının kurulu olduğundan emin olun, eğer dlib kurulumu tamamlandıktan sonra hatayı alırsanız önce aşağıdaki libopenblas-dev kurun ve sonra  dlib’i tekrar kompar etmeniz yani yeniden kurmanız gerekecektir.

sudo apt-get install libopenblas-dev

Başarılı bir şekilde iki paketide yüklediysek artık kurulama geçebiliriz. Bunun için iki farklı kurulum yapabilirsiniz;

1. Yöntem: Otomatik kurulum

sudo pip install dlib

2. Yöntem: Manuel Kurulum

git clone https://github.com/davisking/dlib.git

mkdir build; cd build; cmake .. ; cmake --build .

sudo python setup.py install

Kaynaklar:

[1] http://askubuntu.com/questions/610291/how-to-install-cmake-3-2-on-ubuntu-14-04
[2] http://askubuntu.com/questions/824834/how-to-install-dlib-for-python3-in-ubuntu-14-04
[3] https://github.com/davisking/dlib
[4] http://stackoverflow.com/questions/36893382/scipy-installation-issue-getting-importerror-libopenblas-so-0-cannot-open-sha

Semiha Makinist Uzman on 31 Ocak 2017 yazdı
Yorum Ekle
  • 0 Yanıt(lar)
  • Yanıtınız

    Cevabınızı göndererek Gizlilik Politikası ve Hizmet Şartlarını kabul ediyorsunuz.